<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<title>Mendocino County Counts The Census &#8211; Mendocino TV</title>
<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mendocino TV &raquo; Feed" href="https://mendocinotv.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mendocino TV &raquo; Comments Feed" href="https://mendocinotv.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mendocino TV &raquo; Mendocino County Counts The Census Comments Feed" href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mendocinotv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='validate-engine-css-css'  href='https://mendocinotv.com/wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css?ver=2.13' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://mendocinotv.com/wp-content/plugins/gutenberg/build/block-library/style.css?ver=1585322710' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://mendocinotv.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_style-css'  href='https://mendocinotv.com/wp-content/themes/colormag-pro/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_googlefonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-featured-image-popup-css-css'  href='https://mendocinotv.com/wp-content/themes/colormag-pro/js/magnific-popup/magnific-popup.min.css?ver=20150310' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-fontawesome-css'  href='https://mendocinotv.com/wp-content/themes/colormag-pro/fontawesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://mendocinotv.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.10' type='text/css' media='all' />
<script type='text/javascript' src='https://mendocinotv.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/html5shiv.min.js?ver=5.3.2'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://mendocinotv.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mendocinotv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mendocinotv.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Novel Coronavirus (COVID-19) Press Conference &#8211; March 19, 2020' href='https://mendocinotv.com/2020/03/19/novel-coronavirus-covid-19-press-conference-march-19-2020/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" />
<link rel='shortlink' href='https://mendocinotv.com/?p=17416' />
<link rel="alternate" type="application/json+oembed" href="https://mendocinotv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmendocinotv.com%2F2020%2F03%2F31%2Fmendocino-county-counts-the-census%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mendocinotv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmendocinotv.com%2F2020%2F03%2F31%2Fmendocino-county-counts-the-census%2F&#038;format=xml" />
<link rel="pingback" href="https://mendocinotv.com/xmlrpc.php"><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e8e8e8; }
</style>
	<meta property="og:site_name" content="Mendocino TV">
<meta property="og:type" content="article">
<meta property="og:locale" content="en_US">
<meta property="fb:app_id" content="302230153289392">
<meta property="og:url" content="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/">
<meta property="og:title" content="Mendocino County Counts The Census">
<meta property="og:description" content="The 2020 Census is now happening at My2020Census.gov.">
<meta property="article:published_time" content="2020-04-01T03:03:58+00:00">
<meta property="article:modified_time" content="2020-04-01T03:06:05+00:00">
<meta property="article:author" content="https://mendocinotv.com/author/tvaughn/">
<meta property="article:section" content="Community Channel">
<meta property="article:tag" content="County of Mendocino">
<meta property="article:tag" content="Federal Government">
<meta property="article:tag" content="Government Channel">
<meta property="article:tag" content="Mendocino County">
<meta property="article:tag" content="The Census">
<link rel="icon" href="https://mendocinotv.com/wp-content/uploads/2019/01/MTV-Header-with-Channels-Header-150x34.png" sizes="32x32" />
<link rel="icon" href="https://mendocinotv.com/wp-content/uploads/2019/01/MTV-Header-with-Channels-Header.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://mendocinotv.com/wp-content/uploads/2019/01/MTV-Header-with-Channels-Header.png" />
<meta name="msapplication-TileImage" content="https://mendocinotv.com/wp-content/uploads/2019/01/MTV-Header-with-Channels-Header.png" />
<!-- Mendocino TV Internal Styles -->		<style type="text/css">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</style>
		</head>

<body class="post-template-default single single-post postid-17416 single-format-standard custom-background wp-custom-logo  wide">





<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#main">Skip to content</a>

	
	
	<header id="masthead" class="site-header clearfix ">
		<div id="header-text-nav-container" class="clearfix">

			
							<div class="news-bar">
				<div class="inner-wrap clearfix">
					
		<div class="date-in-header">
			Friday, April 3, 2020		</div>

		
							<div class="breaking-news">
			<strong class="breaking-news-latest">
				Latest:			</strong>
			<ul class="newsticker">
									<li>
						<a href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" title="Mendocino County Counts The Census">Mendocino County Counts The Census</a>
					</li>
									<li>
						<a href="https://mendocinotv.com/2020/03/19/novel-coronavirus-covid-19-press-conference-march-19-2020/" title="Novel Coronavirus (COVID-19) Press Conference &#8211; March 19, 2020">Novel Coronavirus (COVID-19) Press Conference &#8211; March 19, 2020</a>
					</li>
									<li>
						<a href="https://mendocinotv.com/2020/03/07/c-v-starr-communitycenter-fy2019-2020-midyear-budget-report/" title="C. V. Starr Community Center  FY2019-2020 Midyear Budget Report">C. V. Starr Community Center  FY2019-2020 Midyear Budget Report</a>
					</li>
									<li>
						<a href="https://mendocinotv.com/2020/03/04/2019-novel-coronavirus-covid-19-update-for-mendocino-county/" title="2019 Novel Coronavirus (COVID-19) Update for Mendocino County">2019 Novel Coronavirus (COVID-19) Update for Mendocino County</a>
					</li>
									<li>
						<a href="https://mendocinotv.com/2020/02/25/mendocino-coast-district-hospital-board-of-directors-february-27-2020/" title="Mendocino Coast District Hospital Board of Directors February 27 2020">Mendocino Coast District Hospital Board of Directors February 27 2020</a>
					</li>
							</ul>
		</div>
		
					
		
		<div class="social-links clearfix">
			<ul>
				
							</ul>
		</div><!-- .social-links -->
						</div>
			</div>
		
				<div id="wp-custom-header" class="wp-custom-header"><div class="header-image-wrap"><a href="https://mendocinotv.com/" title="Mendocino TV" rel="home"><img src="https://mendocinotv.com/wp-content/uploads/2015/10/cropped-MTV-web-header-Narrow-4.jpg" class="header-image" width="1400" height="150" alt="Mendocino TV"></a></div></div>
				
		<div class="inner-wrap">

			<div id="header-text-nav-wrap" class="clearfix">
				<div id="header-left-section">
											<div id="header-logo-image">
							<a href="https://mendocinotv.com/" class="custom-logo-link" rel="home"><img width="365" height="50" src="https://mendocinotv.com/wp-content/uploads/2013/04/cropped-Mendocino-TV-3-small.jpg" class="custom-logo" alt="Mendocino TV" srcset="https://mendocinotv.com/wp-content/uploads/2013/04/cropped-Mendocino-TV-3-small.jpg 365w, https://mendocinotv.com/wp-content/uploads/2013/04/cropped-Mendocino-TV-3-small-150x21.jpg 150w, https://mendocinotv.com/wp-content/uploads/2013/04/cropped-Mendocino-TV-3-small-300x41.jpg 300w" sizes="(max-width: 365px) 100vw, 365px" /></a>						</div><!-- #header-logo-image -->
											<div id="header-text" class="screen-reader-text">
													<h3 id="site-title">
								<a href="https://mendocinotv.com/" title="Mendocino TV" rel="home">Mendocino TV</a>
							</h3>
						
												<p id="site-description">With Channels, for your viewing pleasure</p>
						<!-- #site-description -->
					</div><!-- #header-text -->
				</div><!-- #header-left-section -->
				<div id="header-right-section">
											<div id="header-right-sidebar" class="clearfix">
							<aside id="colormag_300x250_advertisement_widget-7" class="widget widget_300x250_advertisement clearfix">
		<div class="advertisement_300x250">
						<div class="advertisement-content"><a href="http://ROCKSTOP.COM" class="single_ad_300x250" target="_blank"rel="nofollow">
												<img src="https://mendocinotv.com/wp-content/uploads/2015/07/web_rockstopsign1.gif" width="300" height="250" alt="">
									</a></div>		</div>
		</aside>						</div>
										</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->

		</div><!-- .inner-wrap -->

		
				
				
					<nav id="site-navigation" class="main-navigation clearfix">
				<div class="inner-wrap clearfix">
											<div class="home-icon">
							<a href="https://mendocinotv.com/" title="Mendocino TV"><i class="fa fa-home"></i></a>
						</div>
						
											<div class="search-random-icons-container">
															<div class="top-search-wrap">
									<i class="fa fa-search search-top"></i>
									<div class="search-form-top">
										<form action="https://mendocinotv.com/" class="search-form searchform clearfix" method="get">
	<div class="search-wrap">
		<input type="text" placeholder="Search" class="s field" name="s">
		<button class="search-icon" type="submit"></button>
	</div>
</form><!-- .searchform -->
									</div>
								</div>
													</div>
					
					<p class="menu-toggle"></p>
					<div class="menu-primary-container"><ul id="menu-navigation-bar" class="menu"><li id="menu-item-16272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16272"><a target="_blank" rel="noopener noreferrer" href="https://mendocinotv.com/coast-cinemas-ads/">Coast Cinemas Ads</a></li>
<li id="menu-item-10916" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10916 menu-item-category-303"><a href="https://mendocinotv.com/category/programs/">Local Programs Channel</a>
<ul class="sub-menu">
	<li id="menu-item-14303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14303 menu-item-category-904"><a href="https://mendocinotv.com/category/programs/paranormal-investigation-team-mendocino/">Paranormal Investigation: Team Mendocino</a></li>
	<li id="menu-item-10319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10319 menu-item-category-1483"><a href="https://mendocinotv.com/category/programs/building-healthy-communities/">Building Healthy Communities</a></li>
	<li id="menu-item-14301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14301 menu-item-category-1262"><a href="https://mendocinotv.com/category/programs/mind-body-health-politics/">Mind Body Health &#038; Politics</a></li>
	<li id="menu-item-4808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4808 menu-item-category-294"><a href="https://mendocinotv.com/category/programs/the-abalone-hunter/">The Abalone Hunter</a></li>
	<li id="menu-item-11763" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11763 menu-item-category-1685"><a target="_blank" rel="noopener noreferrer" href="https://mendocinotv.com/category/programs/cannabis-news-views/">Cannabis News &#038; Views</a></li>
	<li id="menu-item-10925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10925 menu-item-category-907"><a href="https://mendocinotv.com/category/programs/the-shift/">The Shift</a></li>
	<li id="menu-item-9261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9261 menu-item-category-480"><a href="https://mendocinotv.com/category/programs/naturally-mendocino/">Naturally Mendocino</a></li>
	<li id="menu-item-14300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14300 menu-item-category-600"><a href="https://mendocinotv.com/category/programs/mendocino-media-makers/">Mendocino Media Makers</a></li>
	<li id="menu-item-14299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14299 menu-item-category-1073"><a href="https://mendocinotv.com/category/programs/hidden-treasures-of-mendocino-county/">Hidden Treasures of Mendocino County</a></li>
	<li id="menu-item-14295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14295 menu-item-category-1404"><a href="https://mendocinotv.com/category/programs/art-beat/">Art Beat</a></li>
</ul>
</li>
<li id="menu-item-14276" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-14276 menu-item-category-733"><a href="https://mendocinotv.com/category/government/">Government Channel</a>
<ul class="sub-menu">
	<li id="menu-item-14286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14286 menu-item-category-1253"><a href="https://mendocinotv.com/category/government/mendocino-coast-district-hospital-district/">Mendocino Coast District Hospital</a></li>
	<li id="menu-item-13433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13433 menu-item-category-1935"><a href="https://mendocinotv.com/category/government/elections/">Elections</a></li>
	<li id="menu-item-14288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14288 menu-item-category-1285"><a href="https://mendocinotv.com/category/government/not-for-profits/">Not for Profits</a></li>
	<li id="menu-item-14287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14287 menu-item-category-735"><a href="https://mendocinotv.com/category/government/musd-government/">Mendocino Unified School District</a></li>
	<li id="menu-item-14285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14285 menu-item-category-1276"><a href="https://mendocinotv.com/category/government/fort-bragg-unified-school-district/">Fort Bragg Unified School District</a></li>
	<li id="menu-item-14278" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-14278 menu-item-category-736"><a href="https://mendocinotv.com/category/government/mendocino-county/">County of Mendocino</a>
	<ul class="sub-menu">
		<li id="menu-item-14279" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14279 menu-item-category-2011"><a href="https://mendocinotv.com/category/government/mendocino-county/noyo/">Noyo Harbor District</a></li>
	</ul>
</li>
	<li id="menu-item-14290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14290 menu-item-category-1244"><a href="https://mendocinotv.com/category/government/politics/">Politics</a></li>
	<li id="menu-item-14291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14291 menu-item-category-737"><a href="https://mendocinotv.com/category/government/state/">State Government</a></li>
	<li id="menu-item-14281" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-14281 menu-item-category-738"><a href="https://mendocinotv.com/category/government/federal/">Federal Government</a>
	<ul class="sub-menu">
		<li id="menu-item-14289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14289 menu-item-category-1388"><a href="https://mendocinotv.com/category/government/not-for-profits/mendocino-coast-clinics/">Mendocino Coast Clinics</a></li>
	</ul>
</li>
	<li id="menu-item-14277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14277 menu-item-category-734"><a href="https://mendocinotv.com/category/government/fort-bragg-government/">City of Fort Bragg</a></li>
</ul>
</li>
<li id="menu-item-14433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14433 menu-item-category-571"><a href="https://mendocinotv.com/category/local-events-channel/">Local Events &#038; Activities Channel</a>
<ul class="sub-menu">
	<li id="menu-item-14314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14314 menu-item-category-479"><a target="_blank" rel="noopener noreferrer" href="https://mendocinotv.com/category/local-events-channel/performances/">Local Performances Channel</a></li>
	<li id="menu-item-14275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14275 menu-item-category-2002"><a href="https://mendocinotv.com/category/food/">Food Channel</a></li>
	<li id="menu-item-14308" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14308 menu-item-category-1311"><a href="https://mendocinotv.com/category/sports/boating/">Boating</a></li>
	<li id="menu-item-14309" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14309 menu-item-category-1313"><a href="https://mendocinotv.com/category/sports/diving/">Diving</a></li>
	<li id="menu-item-14310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14310 menu-item-category-1312"><a href="https://mendocinotv.com/category/sports/fishing/">Fishing</a></li>
	<li id="menu-item-14311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14311 menu-item-category-478"><a href="https://mendocinotv.com/category/sports/">Sports Channel</a>
	<ul class="sub-menu">
		<li id="menu-item-14312" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14312 menu-item-category-475"><a href="https://mendocinotv.com/category/sports/timberwolves-football/">Timberwolves Sports</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-14316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14316 menu-item-category-2010"><a target="_blank" rel="noopener noreferrer" href="https://mendocinotv.com/category/history/">History Channel</a>
<ul class="sub-menu">
	<li id="menu-item-14315" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14315 menu-item-category-522"><a href="https://mendocinotv.com/category/history/memorials/">Memorials</a></li>
	<li id="menu-item-17296" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-17296"><a rel="Kelly House Sunday Afternoon" href="https://mendocinotv.com/2019/10/14/kelly-house-sunday-afternoon-chinese-contribution-to-mendocino/">Kelly House Sunday Afternoon</a></li>
</ul>
</li>
<li id="menu-item-4490" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4490"><a href="https://mendocinotv.com/contact/">Contact</a></li>
<li id="menu-item-9669" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9669"><a href="http://translate.google.com/translate?hl=&#038;sl=auto&#038;tl=es&#038;u=http%3A%2F%2Fmendocinotv.com%2F&#038;sandbox=1">Foreign Language Translation</a></li>
</ul></div>
				</div>
			</nav>
		
		
			
		</div><!-- #header-text-nav-container -->

		
	</header>

		
	<div id="main" class="clearfix">
		
		
		<div class="inner-wrap clearfix">
			
		

<div id="primary">
	<div id="content" class="clearfix">

		
			
<article id="post-17416" class="post-17416 post type-post status-publish format-standard has-post-thumbnail hentry category-community-channel category-mendocino-county category-federal category-government tag-mendocino-county tag-the-census">
	
	
	
	
					<div class="featured-image">
									<a href="https://mendocinotv.com/wp-content/uploads/2012/06/mendocino-county-seal.png" class="image-popup"><img width="176" height="176" src="https://mendocinotv.com/wp-content/uploads/2012/06/mendocino-county-seal.png" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" srcset="https://mendocinotv.com/wp-content/uploads/2012/06/mendocino-county-seal.png 176w, https://mendocinotv.com/wp-content/uploads/2012/06/mendocino-county-seal-150x150.png 150w" sizes="(max-width: 176px) 100vw, 176px" /></a>
											</div>

					
	
	<div class="article-content clearfix">

		
		<div class="above-entry-meta"><span class="cat-links"><a href="https://mendocinotv.com/category/community-channel/" style="background:#adadad" rel="category tag">Community Channel</a>&nbsp;<a href="https://mendocinotv.com/category/government/mendocino-county/" style="background:#91361f" rel="category tag">County of Mendocino</a>&nbsp;<a href="https://mendocinotv.com/category/government/federal/" style="background:#aa1212" rel="category tag">Federal Government</a>&nbsp;<a href="https://mendocinotv.com/category/government/" style="background:#dd9933" rel="category tag">Government Channel</a>&nbsp;</span></div>
			<header class="entry-header">
				<h1 class="entry-title">
					Mendocino County Counts The Census				</h1>
			</header>

			<div class="below-entry-meta ">
			<span class="posted-on"><a href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" title="8:03 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-03-31T20:03:58-07:00">March 31, 2020</time><time class="updated" datetime="2020-03-31T20:06:05-07:00">March 31, 2020</time></a></span>
			<span class="byline"><span class="author vcard" itemprop="name"><i class="fa fa-user"></i><a class="url fn n" href="https://mendocinotv.com/author/tvaughn/" title="Terrence Vaughn">Terrence Vaughn</a></span></span>

			<span class="post-views"><i class="fa fa-eye"></i><span class="total-views">90 Views</span></span>
						<span class="comments"><a href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/#respond"><fb:comments-count xmlns="http://ogp.me/ns/fb#" href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/"></fb:comments-count> Comments</a></span>
			<span class="tag-links"><i class="fa fa-tags"></i><a href="https://mendocinotv.com/tag/mendocino-county/" rel="tag">Mendocino County</a>, <a href="https://mendocinotv.com/tag/the-census/" rel="tag">The Census</a></span></div>
		<div class="entry-content clearfix">
			
<div class="fb-social-plugin fb-send" data-ref="above-post" data-href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/"></div>

<div class="fb-social-plugin fb-like" data-font="lucida grande" data-ref="above-post" data-href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" data-share="true" data-width="285"></div>

<h4>The 2020 Census is now happening at <a href="https://My2020Census.gov">My2020Census.gov</a>.</h4>



<div style="padding:56.25% 0 0 0;position:relative;"><iframe src="https://player.vimeo.com/video/390090270?autoplay=1&amp;title=0&amp;byline=0&amp;portrait=0" style="position:absolute;top:0;left:0;width:100%;height:100%;" allow="autoplay; fullscreen" allowfullscreen="" frameborder="0"></iframe></div><script src="https://player.vimeo.com/api/player.js"></script>



<p></p>

<div class="fb-social-plugin fb-like" data-font="lucida grande" data-ref="below-post" data-href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" data-share="true" data-width="285"></div>
		</div>

			</div>

	</article>

		
	</div><!-- #content -->

	

			<ul class="default-wp-page clearfix thumbnail-pagination">
									<li class="previous">
						<img width="90" height="90" src="https://mendocinotv.com/wp-content/uploads/2012/06/mendocino-county-seal.png" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="" srcset="https://mendocinotv.com/wp-content/uploads/2012/06/mendocino-county-seal.png 176w, https://mendocinotv.com/wp-content/uploads/2012/06/mendocino-county-seal-150x150.png 150w" sizes="(max-width: 90px) 100vw, 90px" /><a href="https://mendocinotv.com/2020/03/19/novel-coronavirus-covid-19-press-conference-march-19-2020/" rel="prev"><span class="meta-nav">&larr; Previous</span> Novel Coronavirus (COVID-19) Press Conference &#8211; March 19, 2020</a>					</li>
				
							</ul>

			
		
		<div class="share-buttons">
	<span class="share">Share This Post:</span>
	<div id="twitter" data-url="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" data-text="Mendocino County Counts The Census" data-title="Tweet This"></div>
	<div id="facebook" data-url="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" data-text="Mendocino County Counts The Census" data-title="Like This"></div>
	<div id="googleplus" data-url="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" data-text="Mendocino County Counts The Census" data-title="+1 This"></div>
	<div id="pinterest" data-url="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" data-text="Mendocino County Counts The Census" data-title="Pin It"></div>
</div><!--/.sharrre-container-->

<script type="text/javascript">
	// Share
	jQuery( document ).ready( function () {
		jQuery( '#twitter' ).sharrre( {
			share          : {
				twitter : true
			},
			template       : '<a class="box" href="#"><div class="count" href="#">{total}</div><div class="share"><i class="fa fa-twitter"></i></div></a>',
			enableHover    : false,
			enableTracking : true,
			click          : function ( api, options ) {
				api.simulateClick();
				api.openPopup( 'twitter' );
			}
		} );
		jQuery( '#facebook' ).sharrre( {
			share          : {
				facebook : true
			},
			template       : '<a class="box" href="#"><div class="count" href="#">{total}</div><div class="share"><i class="fa fa-facebook-square"></i></div></a>',
			enableHover    : false,
			enableTracking : true,
			click          : function ( api, options ) {
				api.simulateClick();
				api.openPopup( 'facebook' );
			}
		} );
		jQuery( '#googleplus' ).sharrre( {
			share          : {
				googlePlus : true
			},
			template       : '<a class="box" href="#"><div class="count" href="#">{total}</div><div class="share"><i class="fa fa-google-plus-square"></i></div></a>',
			enableHover    : false,
			enableTracking : true,
			urlCurl        : 'https://mendocinotv.com/wp-content/themes/colormag-pro/js/sharrre/sharrre.php',
			click          : function ( api, options ) {
				api.simulateClick();
				api.openPopup( 'googlePlus' );
			}
		} );
		jQuery( '#pinterest' ).sharrre( {
			share          : {
				pinterest : true
			},
			template       : '<a class="box" href="#" rel="nofollow"><div class="count" href="#">{total}</div><div class="share"><i class="fa fa-pinterest"></i></div></a>',
			enableHover    : false,
			enableTracking : true,
			buttons        : {
				pinterest : {
					description : 'Mendocino County Counts The Census',
					media       : 'https://mendocinotv.com/wp-content/uploads/2012/06/mendocino-county-seal.png'				}
			},
			click          : function ( api, options ) {
				api.simulateClick();
				api.openPopup( 'pinterest' );
			}
		} );
	} );
</script>


	
	<div class="related-posts-wrapper style-one">

		<h4 class="related-posts-main-title">
			<i class="fa fa-thumbs-up"></i><span>You May Also Like</span>
		</h4>

		<div class="related-posts clearfix ">

							<div class="single-related-posts">

											<div class="related-posts-thumbnail">
							<a href="https://mendocinotv.com/2018/12/21/wreck-of-the-san-juan-to-be-donated-to-roots-of-motive-power-in-willits/" title="Wreck of the San Juan to be donated to Roots of Motive Power in Willits">
								<img width="390" height="200" src="https://mendocinotv.com/wp-content/uploads/2019/01/Noyo-Harbor-Commission-2_4-Title-graphic-1-390x200.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" srcset="https://mendocinotv.com/wp-content/uploads/2019/01/Noyo-Harbor-Commission-2_4-Title-graphic-1-390x200.jpg 390w, https://mendocinotv.com/wp-content/uploads/2019/01/Noyo-Harbor-Commission-2_4-Title-graphic-1-392x200.jpg 392w" sizes="(max-width: 390px) 100vw, 390px" />							</a>
						</div>
					
					<div class="article-content">

						<h3 class="entry-title">
							<a href="https://mendocinotv.com/2018/12/21/wreck-of-the-san-juan-to-be-donated-to-roots-of-motive-power-in-willits/" rel="bookmark" title="Wreck of the San Juan to be donated to Roots of Motive Power in Willits">Wreck of the San Juan to be donated to Roots of Motive Power in Willits</a>
						</h3><!--/.post-title-->

						
													<div class="below-entry-meta ">
								<span class="posted-on"><a href="https://mendocinotv.com/2018/12/21/wreck-of-the-san-juan-to-be-donated-to-roots-of-motive-power-in-willits/" title="1:43 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2018-12-21T13:43:54-08:00">December 21, 2018</time><time class="updated" datetime="2019-01-30T21:16:24-08:00">January 30, 2019</time></a></span>
								<span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://mendocinotv.com/author/tvaughn/" title="Terrence Vaughn">Terrence Vaughn</a></span></span>

																	<span class="comments"><i class="fa fa-comment"></i><a href="https://mendocinotv.com/2018/12/21/wreck-of-the-san-juan-to-be-donated-to-roots-of-motive-power-in-willits/#respond"><fb:comments-count xmlns="http://ogp.me/ns/fb#" href="https://mendocinotv.com/2018/12/21/wreck-of-the-san-juan-to-be-donated-to-roots-of-motive-power-in-willits/"></fb:comments-count> Comments</a></span>
															</div>
						
											</div>

				</div><!--/.related-->
							<div class="single-related-posts">

											<div class="related-posts-thumbnail">
							<a href="https://mendocinotv.com/2018/01/27/city-of-fort-bragg-claims-they-can-produce-public-access-television-cheaper/" title="City of Fort Bragg claims they can produce Public Access Television cheaper">
								<img width="339" height="205" src="https://mendocinotv.com/wp-content/uploads/2018/01/MCM-Bug-1c-339x205.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" />							</a>
						</div>
					
					<div class="article-content">

						<h3 class="entry-title">
							<a href="https://mendocinotv.com/2018/01/27/city-of-fort-bragg-claims-they-can-produce-public-access-television-cheaper/" rel="bookmark" title="City of Fort Bragg claims they can produce Public Access Television cheaper">City of Fort Bragg claims they can produce Public Access Television cheaper</a>
						</h3><!--/.post-title-->

						
													<div class="below-entry-meta ">
								<span class="posted-on"><a href="https://mendocinotv.com/2018/01/27/city-of-fort-bragg-claims-they-can-produce-public-access-television-cheaper/" title="7:59 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2018-01-27T19:59:20-08:00">January 27, 2018</time><time class="updated" datetime="2018-02-01T19:37:45-08:00">February 1, 2018</time></a></span>
								<span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://mendocinotv.com/author/tvaughn/" title="Terrence Vaughn">Terrence Vaughn</a></span></span>

																	<span class="comments"><i class="fa fa-comment"></i><a href="https://mendocinotv.com/2018/01/27/city-of-fort-bragg-claims-they-can-produce-public-access-television-cheaper/#respond"><fb:comments-count xmlns="http://ogp.me/ns/fb#" href="https://mendocinotv.com/2018/01/27/city-of-fort-bragg-claims-they-can-produce-public-access-television-cheaper/"></fb:comments-count> Comments</a></span>
															</div>
						
											</div>

				</div><!--/.related-->
							<div class="single-related-posts">

					
					<div class="article-content">

						<h3 class="entry-title">
							<a href="https://mendocinotv.com/2013/07/13/league-of-women-voters-of-mendocino-county-host-county-budget-meeting/" rel="bookmark" title="League of Women Voters of Mendocino County Host County Budget Meeting">League of Women Voters of Mendocino County Host County Budget Meeting</a>
						</h3><!--/.post-title-->

						
													<div class="below-entry-meta ">
								<span class="posted-on"><a href="https://mendocinotv.com/2013/07/13/league-of-women-voters-of-mendocino-county-host-county-budget-meeting/" title="4:58 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2013-07-13T04:58:51-07:00">July 13, 2013</time><time class="updated" datetime="2013-08-27T16:11:24-07:00">August 27, 2013</time></a></span>
								<span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://mendocinotv.com/author/tvaughn/" title="Terrence Vaughn">Terrence Vaughn</a></span></span>

																	<span class="comments"><i class="fa fa-comment"></i><a href="https://mendocinotv.com/2013/07/13/league-of-women-voters-of-mendocino-county-host-county-budget-meeting/#respond"><fb:comments-count xmlns="http://ogp.me/ns/fb#" href="https://mendocinotv.com/2013/07/13/league-of-women-voters-of-mendocino-county-host-county-budget-meeting/"></fb:comments-count> Comments</a></span>
															</div>
						
											</div>

				</div><!--/.related-->
			
		</div><!--/.post-related-->

	</div>


	
	
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<div class="fb-social-plugin comment-form fb-comments" id="commentform" data-href="https://mendocinotv.com/2020/03/31/mendocino-county-counts-the-census/" data-width="625" data-order-by="social"></div>
</div></div>

</div><!-- #primary -->


<div id="secondary">
			
		<aside id="search-9" class="widget widget_search clearfix"><form action="https://mendocinotv.com/" class="search-form searchform clearfix" method="get">
	<div class="search-wrap">
		<input type="text" placeholder="Search" class="s field" name="s">
		<button class="search-icon" type="submit"></button>
	</div>
</form><!-- .searchform -->
</aside><aside id="paypal_donations-5" class="widget widget_paypal_donations clearfix"><!-- Begin PayPal Donations by https://www.tipsandtricks-hq.com/paypal-donations-widgets-plugin -->

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <div class="paypal-donations">
        <input type="hidden" name="cmd" value="_donations" />
        <input type="hidden" name="bn" value="TipsandTricks_SP" />
        <input type="hidden" name="business" value="9S9GEC6WMYKDU" />
        <input type="hidden" name="item_name" value="Kick Start The News" />
        <input type="hidden" name="rm" value="0" />
        <input type="hidden" name="currency_code" value="USD" />
        <input type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
        <img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" />
    </div>
</form>
<!-- End PayPal Donations -->
</aside><aside id="colormag_125x125_advertisement_widget-7" class="widget widget_125x125_advertisement clearfix">
		<div class="advertisement_125x125">
							<div class="advertisement-title">
					<h3 class="widget-title"><span>Channels</span></h3>				</div>
				<div class="advertisement-content"><a href="https://mendocinotv.com/category/channels/history/" class="single_ad_125x125" target="_blank"rel="nofollow">

						<img src="https://mendocinotv.com/wp-content/uploads/2019/01/History-Channel-Button.png" width="125" height="125" alt="">
										</a><a href="https://mendocinotv.com/category/channels/news-channel/" class="single_ad_125x125" target="_blank"rel="nofollow">

						<img src="https://mendocinotv.com/wp-content/uploads/2019/01/News-Channel-Button.png" width="125" height="125" alt="">
										</a><a href="https://mendocinotv.com/category/channels/government/" class="single_ad_125x125" target="_blank"rel="nofollow">

						<img src="https://mendocinotv.com/wp-content/uploads/2019/01/Govt-Channel-Button-1.png" width="125" height="125" alt="">
										</a><a href="https://mendocinotv.com/category/programs/" class="single_ad_125x125" target="_blank"rel="nofollow">

						<img src="https://mendocinotv.com/wp-content/uploads/2019/01/Local-Programs-Channel-Button.png" width="125" height="125" alt="">
										</a><a href="https://mendocinotv.com/category/local-events-activities-channel/" class="single_ad_125x125" target="_blank"rel="nofollow">

						<img src="https://mendocinotv.com/wp-content/uploads/2019/01/Local-Events-channel-Button-2.png" width="125" height="125" alt="">
										</a><a href="https://mendocinotv.com/category/food/" class="single_ad_125x125" target="_blank"rel="nofollow">

						<img src="https://mendocinotv.com/wp-content/uploads/2019/01/Food-Channel-Button.png" width="125" height="125" alt="">
										</a></div>		</div>
		</aside>      <aside id="mailpoet_form-2" class="widget widget_mailpoet_form clearfix">
  
      <h3 class="widget-title"><span>Subscribe to Our Newsletter</span></h3>
  
  <div id="mailpoet_form_1" class="mailpoet_form mailpoet_form_widget">
    <style type="text/css">.mailpoet_hp_email_label{display:none;}#mailpoet_form_1 .mailpoet_form {  }
#mailpoet_form_1 .mailpoet_paragraph { line-height: 20px; }
#mailpoet_form_1 .mailpoet_segment_label, #mailpoet_form_1 .mailpoet_text_label, #mailpoet_form_1 .mailpoet_textarea_label, #mailpoet_form_1 .mailpoet_select_label, #mailpoet_form_1 .mailpoet_radio_label, #mailpoet_form_1 .mailpoet_checkbox_label, #mailpoet_form_1 .mailpoet_list_label, #mailpoet_form_1 .mailpoet_date_label { display: block; font-weight: bold; }
#mailpoet_form_1 .mailpoet_text, #mailpoet_form_1 .mailpoet_textarea, #mailpoet_form_1 .mailpoet_select, #mailpoet_form_1 .mailpoet_date_month, #mailpoet_form_1 .mailpoet_date_day, #mailpoet_form_1 .mailpoet_date_year, #mailpoet_form_1 .mailpoet_date { display: block; }
#mailpoet_form_1 .mailpoet_text, #mailpoet_form_1 .mailpoet_textarea { width: 200px; }
#mailpoet_form_1 .mailpoet_checkbox {  }
#mailpoet_form_1 .mailpoet_submit input {  }
#mailpoet_form_1 .mailpoet_divider {  }
#mailpoet_form_1 .mailpoet_message {  }
#mailpoet_form_1 .mailpoet_validate_success { font-weight: 600; color: #468847; }
#mailpoet_form_1 .mailpoet_validate_error { color: #b94a48; }</style>
    <form
      target="_self"
      method="post"
      action="https://mendocinotv.com/wp-admin/admin-post.php?action=mailpoet_subscription_form"
      class="mailpoet_form mailpoet_form_form mailpoet_form_widget"
      novalidate
      style=""/* paragraphs (label + input)
    >
      <input type="hidden" name="data[form_id]" value="1" />
      <input type="hidden" name="token" value="f1cf717f85" />
      <input type="hidden" name="api_version" value="v1" />
      <input type="hidden" name="endpoint" value="subscribers" />
      <input type="hidden" name="mailpoet_method" value="subscribe" />

      <label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"/></label><div class="mailpoet_paragraph"><label class="mailpoet_text_label" data-automation-id="form_first_name_label" >First name</label><input type="text" class="mailpoet_text" name="data[form_field_MDcyNjI4YzIzMzM2X2ZpcnN0X25hbWU=]" title="First name" value="" data-automation-id="form_first_name" /></div>
<div class="mailpoet_paragraph"><label class="mailpoet_text_label" data-automation-id="form_email_label" >Email <span class="mailpoet_required">*</span></label><input type="email" class="mailpoet_text" name="data[form_field_OTUxMmRhZjRkMDZhX2VtYWls]" title="Email" value="" data-automation-id="form_email" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required."/></div>
<div class="mailpoet_paragraph" >We keep your data private and share your data only with third parties that make this service possible. <a href="">Read our Privacy Policy.</a></div>
<div class="mailpoet_paragraph"><input type="submit" class="mailpoet_submit" value="Subscribe!" data-automation-id="subscribe-submit-button" /><span class="mailpoet_form_loading"><span class="mailpoet_bounce1"></span><span class="mailpoet_bounce2"></span><span class="mailpoet_bounce3"></span></span></div>

      <div class="mailpoet_message">
        <p class="mailpoet_validate_success"
                style="display:none;"
                >Check your inbox or spam folder to confirm your subscription.
        </p>
        <p class="mailpoet_validate_error"
                style="display:none;"
                >        </p>
      </div>
    </form>
  </div>

      </aside>
  <aside id="search-8" class="widget widget_search clearfix"><form action="https://mendocinotv.com/" class="search-form searchform clearfix" method="get">
	<div class="search-wrap">
		<input type="text" placeholder="Search" class="s field" name="s">
		<button class="search-icon" type="submit"></button>
	</div>
</form><!-- .searchform -->
</aside><aside id="linkcat-154" class="widget widget_links clearfix"><h3 class="widget-title"><span>Links to local calendars</span></h3>
	<ul class='xoxo blogroll'>
<li><a href="http://www.artsmendocino.org/index.php?option=com_zcalendar&#038;viewid=4&#038;Itemid=1" rel="friend met colleague" title="online resource for art events and opportunities in Mendocino County." target="_blank">Arts Council of Mendocino County</a></li>
<li><a href="http://www.mendocinocoast.com/cgi-bin/mendocinocoast/calendar/calendar.pl?calendar=eventcal&#038;style=List" rel="colleague" title="Mendocino Coast Chamber of Commerce Calendar" target="_blank">Mendocino Coast Chamber of Commerce Calendar</a></li>
<li><a href="http://www.fortbragg.com/" rel="colleague" title="What&#8217;s happening in Fort Bragg" target="_blank">What&#039;s Happening in Fort Bragg</a></li>

	</ul>
</aside>
<aside id="calendar-2" class="widget widget_calendar clearfix"><h3 class="widget-title"><span>Upcoming Broadcasts</span></h3><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>March 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="https://mendocinotv.com/2020/02/">&laquo; Feb</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="6" class="pad">&nbsp;</td><td>1</td>
	</tr>
	<tr>
		<td>2</td><td>3</td><td><a href="https://mendocinotv.com/2020/03/04/" aria-label="Posts published on March 4, 2020">4</a></td><td>5</td><td>6</td><td><a href="https://mendocinotv.com/2020/03/07/" aria-label="Posts published on March 7, 2020">7</a></td><td>8</td>
	</tr>
	<tr>
		<td>9</td><td>10</td><td>11</td><td>12</td><td>13</td><td>14</td><td>15</td>
	</tr>
	<tr>
		<td>16</td><td>17</td><td>18</td><td><a href="https://mendocinotv.com/2020/03/19/" aria-label="Posts published on March 19, 2020">19</a></td><td>20</td><td>21</td><td>22</td>
	</tr>
	<tr>
		<td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td>
	</tr>
	<tr>
		<td>30</td><td><a href="https://mendocinotv.com/2020/03/31/" aria-label="Posts published on March 31, 2020">31</a></td>
		<td class="pad" colspan="5">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>			<div class="weather-api-error">
				OpenWeatherMap requires API Key to work.				<a href="http://openweathermap.org/appid">Get API Key</a>
			</div>
			
	</div>



</div><!-- .inner-wrap -->
</div><!-- #main -->

	<div class="advertisement_above_footer">
		<div class="inner-wrap">
			<aside id="tag_cloud-6" class="widget widget_tag_cloud clearfix"><h3 class="widget-title"><span>Tags</span></h3><div class="tagcloud"><a href="https://mendocinotv.com/tag/abalone/" class="tag-cloud-link tag-link-201 tag-link-position-1" style="font-size: 9.2444444444444pt;" aria-label="abalone (18 items)">abalone</a>
<a href="https://mendocinotv.com/tag/amy-mccolley/" class="tag-cloud-link tag-link-1956 tag-link-position-2" style="font-size: 12.355555555556pt;" aria-label="Amy McColley (29 items)">Amy McColley</a>
<a href="https://mendocinotv.com/tag/building-health-communities/" class="tag-cloud-link tag-link-1836 tag-link-position-3" style="font-size: 14.688888888889pt;" aria-label="Building Health Communities (42 items)">Building Health Communities</a>
<a href="https://mendocinotv.com/tag/building-healthy-communities/" class="tag-cloud-link tag-link-1484 tag-link-position-4" style="font-size: 19.355555555556pt;" aria-label="Building Healthy Communities (85 items)">Building Healthy Communities</a>
<a href="https://mendocinotv.com/tag/ceo-bob-edwards/" class="tag-cloud-link tag-link-1671 tag-link-position-5" style="font-size: 13.133333333333pt;" aria-label="CEO Bob Edwards (33 items)">CEO Bob Edwards</a>
<a href="https://mendocinotv.com/tag/cfo-mike-ellis/" class="tag-cloud-link tag-link-1850 tag-link-position-6" style="font-size: 13.288888888889pt;" aria-label="CFO Mike Ellis (34 items)">CFO Mike Ellis</a>
<a href="https://mendocinotv.com/tag/chris-skyhawk/" class="tag-cloud-link tag-link-1816 tag-link-position-7" style="font-size: 8.4666666666667pt;" aria-label="Chris Skyhawk (16 items)">Chris Skyhawk</a>
<a href="https://mendocinotv.com/tag/city-of-fort-bragg/" class="tag-cloud-link tag-link-473 tag-link-position-8" style="font-size: 13.6pt;" aria-label="city of fort bragg (35 items)">city of fort bragg</a>
<a href="https://mendocinotv.com/tag/doug-waldo/" class="tag-cloud-link tag-link-256 tag-link-position-9" style="font-size: 8.9333333333333pt;" aria-label="Doug Waldo (17 items)">Doug Waldo</a>
<a href="https://mendocinotv.com/tag/dr-kevin-miller/" class="tag-cloud-link tag-link-1571 tag-link-position-10" style="font-size: 9.5555555555556pt;" aria-label="Dr. Kevin Miller (19 items)">Dr. Kevin Miller</a>
<a href="https://mendocinotv.com/tag/dr-peter-glusker/" class="tag-cloud-link tag-link-1690 tag-link-position-11" style="font-size: 8.4666666666667pt;" aria-label="Dr Peter Glusker (16 items)">Dr Peter Glusker</a>
<a href="https://mendocinotv.com/tag/fbusd/" class="tag-cloud-link tag-link-1348 tag-link-position-12" style="font-size: 9.5555555555556pt;" aria-label="FBUSD (19 items)">FBUSD</a>
<a href="https://mendocinotv.com/tag/football/" class="tag-cloud-link tag-link-484 tag-link-position-13" style="font-size: 14.066666666667pt;" aria-label="football (38 items)">football</a>
<a href="https://mendocinotv.com/tag/fort-bragg/" class="tag-cloud-link tag-link-8 tag-link-position-14" style="font-size: 15.311111111111pt;" aria-label="Fort Bragg (46 items)">Fort Bragg</a>
<a href="https://mendocinotv.com/tag/fort-bragg-city-council/" class="tag-cloud-link tag-link-177 tag-link-position-15" style="font-size: 13.911111111111pt;" aria-label="Fort Bragg City Council (37 items)">Fort Bragg City Council</a>
<a href="https://mendocinotv.com/tag/fort-bragg-football/" class="tag-cloud-link tag-link-483 tag-link-position-16" style="font-size: 8.9333333333333pt;" aria-label="fort bragg football (17 items)">fort bragg football</a>
<a href="https://mendocinotv.com/tag/fort-bragg-timberwolves/" class="tag-cloud-link tag-link-765 tag-link-position-17" style="font-size: 14.222222222222pt;" aria-label="Fort Bragg Timberwolves (39 items)">Fort Bragg Timberwolves</a>
<a href="https://mendocinotv.com/tag/fort-bragg-unified-school-district/" class="tag-cloud-link tag-link-1231 tag-link-position-18" style="font-size: 12.355555555556pt;" aria-label="Fort Bragg Unified School District (29 items)">Fort Bragg Unified School District</a>
<a href="https://mendocinotv.com/tag/ft-bragg-timberwolves/" class="tag-cloud-link tag-link-819 tag-link-position-19" style="font-size: 8.4666666666667pt;" aria-label="Ft Bragg Timberwolves (16 items)">Ft Bragg Timberwolves</a>
<a href="https://mendocinotv.com/tag/jessica-grinberg/" class="tag-cloud-link tag-link-2041 tag-link-position-20" style="font-size: 10.8pt;" aria-label="Jessica Grinberg (23 items)">Jessica Grinberg</a>
<a href="https://mendocinotv.com/tag/joe-caito/" class="tag-cloud-link tag-link-569 tag-link-position-21" style="font-size: 8.4666666666667pt;" aria-label="joe caito (16 items)">joe caito</a>
<a href="https://mendocinotv.com/tag/john-redding/" class="tag-cloud-link tag-link-1958 tag-link-position-22" style="font-size: 13.288888888889pt;" aria-label="John Redding (34 items)">John Redding</a>
<a href="https://mendocinotv.com/tag/karen-arnold/" class="tag-cloud-link tag-link-1957 tag-link-position-23" style="font-size: 12.355555555556pt;" aria-label="Karen Arnold (29 items)">Karen Arnold</a>
<a href="https://mendocinotv.com/tag/lindy-peters/" class="tag-cloud-link tag-link-548 tag-link-position-24" style="font-size: 12.822222222222pt;" aria-label="lindy peters (31 items)">lindy peters</a>
<a href="https://mendocinotv.com/tag/marianne-mcgee/" class="tag-cloud-link tag-link-606 tag-link-position-25" style="font-size: 16.866666666667pt;" aria-label="marianne mcgee (58 items)">marianne mcgee</a>
<a href="https://mendocinotv.com/tag/mcdh/" class="tag-cloud-link tag-link-1158 tag-link-position-26" style="font-size: 22pt;" aria-label="MCDH (124 items)">MCDH</a>
<a href="https://mendocinotv.com/tag/mcdh-board-of-directors/" class="tag-cloud-link tag-link-1255 tag-link-position-27" style="font-size: 21.066666666667pt;" aria-label="MCDH Board of Directors (108 items)">MCDH Board of Directors</a>
<a href="https://mendocinotv.com/tag/mcdh-parcel-tax/" class="tag-cloud-link tag-link-1828 tag-link-position-28" style="font-size: 9.2444444444444pt;" aria-label="MCDH Parcel Tax (18 items)">MCDH Parcel Tax</a>
<a href="https://mendocinotv.com/tag/mcdh-planning-committee/" class="tag-cloud-link tag-link-1644 tag-link-position-29" style="font-size: 11.888888888889pt;" aria-label="MCDH Planning Committee (27 items)">MCDH Planning Committee</a>
<a href="https://mendocinotv.com/tag/mchd/" class="tag-cloud-link tag-link-1412 tag-link-position-30" style="font-size: 18.266666666667pt;" aria-label="MCHD (72 items)">MCHD</a>
<a href="https://mendocinotv.com/tag/mchd-board-of-directors/" class="tag-cloud-link tag-link-1500 tag-link-position-31" style="font-size: 18.266666666667pt;" aria-label="MCHD Board of Directors (72 items)">MCHD Board of Directors</a>
<a href="https://mendocinotv.com/tag/mendocino/" class="tag-cloud-link tag-link-7 tag-link-position-32" style="font-size: 13.911111111111pt;" aria-label="Mendocino (37 items)">Mendocino</a>
<a href="https://mendocinotv.com/tag/mendocino-coast-district-hospital/" class="tag-cloud-link tag-link-790 tag-link-position-33" style="font-size: 21.688888888889pt;" aria-label="Mendocino Coast District Hospital (118 items)">Mendocino Coast District Hospital</a>
<a href="https://mendocinotv.com/tag/mendocino-coast-district-hospital-board-of-directors/" class="tag-cloud-link tag-link-1214 tag-link-position-34" style="font-size: 18.422222222222pt;" aria-label="Mendocino Coast District Hospital Board of Directors (73 items)">Mendocino Coast District Hospital Board of Directors</a>
<a href="https://mendocinotv.com/tag/mendocino-coast-healthcare-district/" class="tag-cloud-link tag-link-1413 tag-link-position-35" style="font-size: 14.222222222222pt;" aria-label="Mendocino Coast Healthcare District (39 items)">Mendocino Coast Healthcare District</a>
<a href="https://mendocinotv.com/tag/mendocino-county/" class="tag-cloud-link tag-link-15 tag-link-position-36" style="font-size: 8pt;" aria-label="Mendocino County (15 items)">Mendocino County</a>
<a href="https://mendocinotv.com/tag/mendocino-tv/" class="tag-cloud-link tag-link-20 tag-link-position-37" style="font-size: 12.977777777778pt;" aria-label="Mendocino TV (32 items)">Mendocino TV</a>
<a href="https://mendocinotv.com/tag/mendoicno-coast-healthcare-district/" class="tag-cloud-link tag-link-1829 tag-link-position-38" style="font-size: 10.177777777778pt;" aria-label="Mendoicno Coast Healthcare District (21 items)">Mendoicno Coast Healthcare District</a>
<a href="https://mendocinotv.com/tag/naturally-mendocino-2/" class="tag-cloud-link tag-link-519 tag-link-position-39" style="font-size: 9.2444444444444pt;" aria-label="naturally mendocino (18 items)">naturally mendocino</a>
<a href="https://mendocinotv.com/tag/president-steve-lund/" class="tag-cloud-link tag-link-1707 tag-link-position-40" style="font-size: 11.577777777778pt;" aria-label="President Steve Lund (26 items)">President Steve Lund</a>
<a href="https://mendocinotv.com/tag/skip-taube/" class="tag-cloud-link tag-link-371 tag-link-position-41" style="font-size: 9.2444444444444pt;" aria-label="Skip Taube (18 items)">Skip Taube</a>
<a href="https://mendocinotv.com/tag/steve-lund/" class="tag-cloud-link tag-link-1641 tag-link-position-42" style="font-size: 11.111111111111pt;" aria-label="Steve Lund (24 items)">Steve Lund</a>
<a href="https://mendocinotv.com/tag/ted-williams/" class="tag-cloud-link tag-link-1408 tag-link-position-43" style="font-size: 8.4666666666667pt;" aria-label="Ted Williams (16 items)">Ted Williams</a>
<a href="https://mendocinotv.com/tag/terrence-vaughn/" class="tag-cloud-link tag-link-93 tag-link-position-44" style="font-size: 14.377777777778pt;" aria-label="Terrence Vaughn (40 items)">Terrence Vaughn</a>
<a href="https://mendocinotv.com/tag/timberwolves/" class="tag-cloud-link tag-link-482 tag-link-position-45" style="font-size: 10.488888888889pt;" aria-label="timberwolves (22 items)">timberwolves</a></div>
</aside>		</div>
	</div>



<footer id="colophon" class="clearfix  ">
	
<div class="footer-widgets-wrapper">
	<div class="inner-wrap">
		<div class="footer-widgets-area clearfix">
			<div class="tg-upper-footer-widgets clearfix">
				<div class="footer_upper_widget_area tg-one-third">
					<aside id="facebook-like-6" class="widget widget_facebook_like clearfix"><div class="fb-like" data-ref="widget"></div></aside>				</div>
				<div class="footer_upper_widget_area tg-one-third">
									</div>
				<div class="footer_upper_widget_area tg-one-third tg-one-third-last">
									</div>
			</div>

			<div class="tg-footer-main-widget">
				<div class="tg-first-footer-widget">
									</div>
			</div>

			<div class="tg-footer-other-widgets">
				<div class="tg-second-footer-widget">
									</div>
				<div class="tg-third-footer-widget">
									</div>
				<div class="tg-fourth-footer-widget">
									</div>
			</div>

			<div class="footer-full-width-sidebar inner-wrap clearfix">
							</div>
		</div>
	</div>
</div>
	<div class="footer-socket-wrapper clearfix">
		<div class="inner-wrap">
			<div class="footer-socket-area">
				<div class="footer-socket-right-section">
					
		
		<div class="social-links clearfix">
			<ul>
				
							</ul>
		</div><!-- .social-links -->
		
					<nav class="footer-menu clearfix">
											</nav>
				</div>

				<div class="footer-socket-left-section">
					<div class="copyright">Copyright ©  2019] www.mendocinotv.com All rights reserved. <br>Theme: ColorMag by  <a href="https://themegrill.com/wordpress-themes/" target="_blank" title="ThemeGrill" rel="author"><span>ThemeGrill</span></a>. Powered by  <a href="http://wordpress.org" target="_blank" title="WordPress"><span>WordPress</span></a>.</div>				</div>
			</div>

		</div>
	</div>
</footer>

	<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>

	<div class="reading-progress-bar"></div>


</div><!-- #page -->
<link rel='stylesheet' id='mailpoet_public-css'  href='https://mendocinotv.com/wp-content/plugins/mailpoet/assets/dist/css/mailpoet-public.3eaa9430.css?ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/mendocinotv.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/news-ticker/jquery.newsTicker.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/magnific-popup/jquery.magnific-popup.min.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/navigation.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/fitvids/jquery.fitvids.min.js?ver=1.2.0'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/sharrre/jquery.sharrre.min.js?ver=20150304'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/prognroll/prognroll.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/skip-link-focus-fix.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var colormag_ticker_settings = {"breaking_news_slide_effect":"down","breaking_news_duration":"4000","breaking_news_speed":"1000"};
var colormag_progress_bar_bgcolor = {"bg_color":"#222222"};
var colormag_load_more = {"tg_nonce":"182de12fbb","ajax_url":"https:\/\/mendocinotv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/colormag-custom.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var colormag_script_vars = {"no_more_posts":"No more post"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/themes/colormag-pro/js/loadmore.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"302230153289392"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="https:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript' src='https://mendocinotv.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/plugins/mailpoet/assets/dist/js/vendor.87f5a633.js?ver=3.46.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var MailPoetForm = {"ajax_url":"https:\/\/mendocinotv.com\/wp-admin\/admin-ajax.php","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendocinotv.com/wp-content/plugins/mailpoet/assets/dist/js/public.38c81db3.js?ver=3.46.6'></script>
<script type='text/javascript'>
function initMailpoetTranslation() {
  if (typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<div id="fb-root"></div></body>
</html>
